Ремонт и диагностика

Pptp на ios 10 – Настройка PPTP VPN соединения на iPhone, iPad, iPod Touch в iOS 10

Инструкция для настройки VPN на iPhone в iOS 10

После выпуска iOS 10 в операционной системе исчезла возможность выхода через VPN по системе PPTP VPN.

Инженеры компании Apple посчитали, что PPTP VPN менее надежно, чем другие соединения VPN, потому и была убрана. Однако некоторые пользователи столкнулись с тем, что их провайдер услуг, не предоставляет другие способы подключения к VPN. К счастью, есть способ настройки для PPTP для iOS 10 и выше.

1. Установить программу OpenVPN Connect в AppStore.

2. Импортировать настройки от вашего VPN провайдера в установленную программу OpenVPN.

Подключить iPhone к компьютеру и зайти в него через iTunes. Открыть раздел «Устройство», далее вкладка «Программы». Опустить к списку программ с заголовком «Общие файлы».

Выбрать программу OpenVPN и добавить в неё конфигурационные файлы. Обычно они состоят из тех же файлов, которые используются для выхода в интернет через VPN с помощью Android телефонов. Файлы с расширениями «.ovpn», «.crt» и «.key».

Загружать нужно по одному профилю за раз. Т.е. если конфигураций .ovpn несколько, то сначала загружаем один файл «.ovpn» и все файлы «.crt» и «.key». Проделываем процедуру описанную ниже. А только потом загружаем второй файл «.ovpn» и повторно файлы «.crt» и «.key».

3. Запустить программу OpenVPN на iPhone. Если конфигурация была загружена верная, то вверху программы появится уведомление: «New profiles are available…». И под этим заголовком появится новый тип соединения. Для сохранения этого соединения нажимаем на зеленый плюсик.

В первом подключении iOS запросит разрешение на использование программы OpenVPN. Подтверждаем.

Далее заходим в сохраненный профиль. Вводим логин и пароль, нажимаем на ползунок сохранить.

Настройка профиля готова. Ниже кнопка подключения, нажав на неё начнет устанавливаться соединение.

При успешном подключении вверху экрана на телефоне отобразится индикатор VPN.

Отключить VPN можно и через обычные настройки телефона.

ploshadka.net

Настройки VPN соединения, туннеля для Apple iOS, L2TP IPsec

Просмотров: 4555

1. Войдите в меню настроек

2. Выберите пункт «Основные», а затем в нем выберите пункт «VPN»

                      

 

3. Добавьте конфигурацию VPN с типом L2TP:

                     

4. Введите описание vpnki и адрес сервера — vpnki.ru 

5. Введите имя учетной записи туннеля, полученной в системе vpnki (например userXX)

6. Заполните поля с паролем и общим кючом — vpnki

7. Проверьте, чтобы переключатель Для всех данных был отключен

8. Сохраните профиль и попробуйте подключиться к VPN, сдвинув переключатель в сторке Статус.

9. При успешном подключении статус изменится на «Подключено» и в строке состояния появится иконка [VPN]

10. Поздравляем! Вы успешно подключили свое устройство

        

11. Для удобства включения и отключения VPN на главном экране настроек появится переключатель:

PS: В целях борьбы с зависшими сессиями мы принудительно отключаем пользовательские туннели с протоколами PPTP, L2TP, L2TP/IPsec через 24 часа после установления соединения. При правильной настройке соединения должны автоматически переустановиться.

 

Наша система будет работать с многими типами домашних и офисных маршрутизаторов. Более подробно смотрите в разделе по настройке оборудования, а начать настройку лучше с этого примера.

ДОПОЛНИТЕЛЬНО ПО ТЕМЕ

  • Про VPN и протоколы можно почитать здесь

 

vpnki.ru

Настройки безопасности iOS 10, на которые следует обратить внимание / Блог компании ESET NOD32 / Хабр

Сегодня Apple выпустила iOS 10. Пользователи iPhone 5+, iPad mini 2+, iPad 4, iPad Air 1/2, iPad Pro, а так же iPod touch 6 уже могут установить обновление на свои устройства. О функциях этой новой версии мобильной ОС от Apple уже достаточно написано в различных обзорах, так что не будет повторять эту информацию еще раз. Вместо этого, остановимся более детально на ее настройках конфиденциальности и безопасности. Отметим, что в iOS 10 Apple переключилась на более безопасный механизм доставки обновлений — протокол HTTPS. Этой новой security функцией Apple исправляет уязвимость с идентификатором CVE-2016-4741, которая позволяла атакующим удаленно блокировать доставку обновлений устройству с iOS. Apple также исправила проблему с OTA-обновлением iOS 10 для устройств, на которую уже успели пожаловаться некоторые владельцы устройств iDevice.

Ниже представлен список функций безопасности и конфиденциальности, на которые следует обратить внимание в iOS 10.

Конфиденциальность панели Сегодня

В iOS 10 появилась новая панель Сегодня, на которой размещаются различные виджеты и их информация. Панель доступна для получения информации на заблокированном экране устройства. Предназначение панели Сегодня является одновременно узким местом в системе конфиденциальности iOS, так как виджеты могут размещать там частную информацию пользователя. Для удаления виджета с панели Сегодня следует зайти в нее, прокрутить до конца и выбрать пункт Изменить.

Доступные операции на заблокированном устройстве

iOS 10 разрешает пользователю использовать широкий спектр критичных для безопасности операций на заблокированном устройстве. Например, пользователь может получать доступ к своему электронному кошельку или просмотреть уведомления. Все перечисленные выше функции могут быть отключены. Можно даже отключить панель Сегодня, так что она будет недоступна с заблокированного устройства. Для этого следует зайти в меню Настройки → Защита код-паролем.

Надежный код разблокировки устройства

iOS 10, как и предыдущие версии, использует встроенное файловое шифрование данных на устройстве. Отдельные файлы шифруются надежным алгоритмом с помощью ключа шифрования, частью которого выступает код разблокировки устройства. Таким образом Apple гарантирует, что никто не сможет получить доступ к зашифрованным данным. Надежный код разблокировки также важен для самого блокирования устройства, чем больше в нем предусмотрено символов, тем более стойкую комбинацию цифр или букв можно задать. Для изменения настроек кода разблокировки следует зайти в Настройки → Код-пароль → Сменить код-пароль → Параметры код-пароля. Там можно задать шестизначный код или пароль.

Настройки геолокации для системы

iOS 10 позволяет различным системным службам получать данные о месторасположении пользователя. Эту ситуацию можно контролировать для каждой службы. Для этого следует перейти в Настройки → Конфиденциальность → Службы геолокации → Системные службы. Для удаления истории списка посещенных мест, следует выбрать пункт «Часто посещаемые места» и выбрать настройку «Очистить историю…». Для отключения всех пунктов можно выключить настройку «Службы геолокации» целиком.

Функция «Найти iPhone»

Эта функция является хорошо известной и позволяет с использованием сервиса iCloud определить месторасположение устройства, которое имеет связь с интернетом. В случае утери устройства, функция помогает пользователю заблокировать устройство или стереть с него данные. Для включения этой функции следует зайти в Настройки → iCloud → Найти iPhone. Другая настройка под названием «Последняя геопозиция» позволяет устройству отправить на сервер информацию о последнем месторасположении устройства перед полной разрядкой аккумулятора.

Настройка режима запроса кода разблокировки при покупках в iTunes и App Store

Следует использовать настройку «Всегда запрашивать пароль для дополнительных покупок на этом устройстве». Эта функция не позволит другим лицам воспользоваться вашим счетом iTunes и App Store для покупок даже на разблокированном устройстве. Данная мера также исключит возможность списывания несколько раз денежных средств с кредитной карты после того как уже была пройдена авторизация для нее. Вам следует будет ввести пароль Apple ID каждый раз при совершении покупки или списывании денежных средств.

Ограничение приложениям доступа к данным геопозиции

iOS 10 позволяет контролировать список приложений, которым разрешен доступ к данным геопозиции пользователя. Не следует разрешать получение данной информации тем приложениям, которым вы не доверяете. Для проверки данной настройки следует выбрать приложение из списка в меню настроек и задать соответствующий режим пункта Геопозиция.

Ограничение приложениям доступа к данным контактов

Схожая с предыдущей функцией мера, которая запрещает приложению получения доступа к контактам. Список сторонних приложений, которые имеют доступ к контактам, можно получить в меню Настройки → Конфиденциальность → Контакты.

Время жизни сообщений и звонков

Начиная с iOS 8, в приложении iMessage (Сообщения) появилась возможность отправлять звуковые и видео сообщения. iOS 10 позволяет задать время хранения таких сообщений на устройстве. Для настройки следует зайти в меню Настройки → Сообщения и выбрать пункт «Оставить сообщения», а также Аудиосообщения. Далее следует выбрать время хранения сообщений.

Конфиденциальность уведомлений

Одним из ключевых пунктов конфиденциальности данных является информация, которую пользователь разрешает iOS показывать на заблокированном экране устройства. iOS может показывать как часть входящего сообщения или электронного письма, так и не показывать его вовсе, что является наиболее оптимальным для пользователя с точки зрения конфиденциальности. Активная настройка «Показывать миниатюры» в меню Настройки → Уведомления свидетельствует о том, что iOS будет разглашать часть информации сообщений на заблокированном экране.

Двухфакторная аутентификация

Apple, как и другие известные онлайн-сервисы, уже не раз рекомендовала использовать 2FA аутентификацию для подтверждения входа. Такая функция может быть включена в аккаунте Apple ID. После ее включения пользователю нужно будет дополнительно подтверждать свою личность при изменении настроек аккаунта или при совершении покупок в App Store и iTunes с нового устройства. Подробнее о ее включении можно прочитать здесь.


be secure.

habr.com

IPSec over L2TP между RouterOS и Apple iOS 10

В 10 версии iOS команда Apple наконец-то выпилила PPTP, чем сподвигла весь (не)цивилизованный ИТ-мир срочно учиться поднимать IPSec на своих бордерах. В том числе и меня.

«Поднять IPSec — что там сложного» — подумал я. Но не тут то было. По мануалам, хабрам и прочим ресурсам все отлично поднимается и работает между двумя микротиками, между микротиком и виндой, между микротиком и андроид. Но вот с iOS 10 ни в какую не хочет. Путем долгих ковыряний и трехэтажных словосочетаний, выяснил, что изменения для IPSec нужно применять в КОНСОЛИ! Не в графическом интерфейсе, а именно в консоли — ssh или встроенная в WinBox — без разницы. Но факт в том, что идентичные настройки в WinBox не позволяли поднять VPN между Mikrotik RouterOS и IPhone (по крайней мере в моем случае с RB751 на RouterOS 6.37.1 в связке с IPhone 6).

Привожу настройки L2TP и IPSec текстом и скрины из WinBox что должно получиться:

L2TP сервер
/interface l2tp-server server
set authentication=mschap2 default-profile=default enabled=yes

L2TP server

PPP профили дефолтные
> ppp profile print 
Flags: * — default 
 0 * name=»default» use-mpls=default use-compression=default 
     use-encryption=default only-one=default change-tcp-mss=yes 
     use-upnp=default address-list=»» on-up=»» on-down=»» 

 1 * name=»default-encryption» use-mpls=default use-compression=default 
     use-encryption=yes only-one=default change-tcp-mss=yes use-upnp=default 
     address-list=»» on-up=»» on-down=»»

ppp profile

Пользователь L2TP тоже ничем не отличается от простого L2TP/PPTP и иже с ними без айписека

/ppp secret

add local-address=192.168.222.16 name=user1 password=l2tppassword profile=default-encryption remote-address=192.168.222.18 service=l2tp

L2TP secret

Приступаем к IPSec. Все, что я делал с IPSec — делал через консоль. Из винбокса не заработало. что именно сделалось не так — не проверял. Можете проверить методом исключения.

Добавляем группу (дефолтная работает криво — особенность RouterOS):
/ip ipsec policy group
add name=l2tp

IPSec group

Корректируем proposal и добавляем новый:

/ip ipsec proposal

set [ find default=yes ] enc-algorithms=aes-256-cbc,aes-128-cbc

add enc-algorithms=aes-256-cbc,aes-128-cbc name=L2TP pfs-group=none

IPSec proposal

Добавляем пира:

/ip ipsec peer

add enc-algorithm=aes-256,aes-192,aes-128,3des exchange-mode=main-l2tp generate-policy=port-strict passive=yes policy-template-group=l2tp secret=RouterOS

IPSec peer

Добавляем шаблон политики:

/ip ipsec policy

add dst-address=0.0.0.0/0 group=l2tp proposal=L2TP src-address=0.0.0.0/0 template=yes

IPSec policy

IPSec policy action

Ну и настройка IPhone:

IPhone

Спасибо Кириллу Васильеву за наводку

UPD: если имеются проблемы с подключением, попробуйте в /ip ipsec peer generate-policy установить port-override вместо port-strict 

UPD: как советуют в комментариях

www.bubnovd.net

Отправить ответ

avatar
  Подписаться  
Уведомление о